Error:
Attempting the online activation of the LANCOM Advanced VPN Client fails by returning the error message "An error occurred: 10001 4"; see the figure below:
In the case of an offline activation the activation server returns the error number: 10101 -3; see the figure below:


Cause:
The installed software version of the LANCOM Advanced VPN Client is older than the licensed version.
Example: The system is installed with software version 2.03, but the license is based on version 2.10.
The software does not recognize the license key and serial number of the newer license. Activation is impossible. For licensing and activation, the software version must be >= the license version.

Solution:
In the LANCOM Advanced VPN Client, navigate to the Help menu and select the option "Search for updates" (see figure below). This will find the latest version of the LANCOM Advanced VPN Client and execute an update.